juhua624536.cn
我們隻提供有用的幹貨

老師好,請改這個放文華 (文華财經WH6赢順V6.7)

投資者咨詢:老師好,請改這個放文華 (文華财經WH6赢順V6.7)
來源:文華财經  日期:2019/8/24 21:14
 請幫忙把這個指标改成能導入文華使用,謝謝。

DDIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),NODRAW;
DDEA:EMA(DDIF,MID),NODRAW;
DMACD:(DDIF-DDEA)*2,NODRAW;

上市天數:=BARSCOUNT(C); N:=IF(上市天數<90,上市天數-1,90);
基點:=CONST(LLV(L,N)); 基:=CONST(HHV(H,N))-基點;
分:=CONST(LLV(DDIF,N)); 百:=CONST(HHV(DDIF,N))-分;
CC比:=(DDIF-分)/百; XCX:=CC比*基+基點;
DIF:=XCX; NOTEXTDDIF:DIF,NODRAW;
DEA:=EMA(DIF,9); NOTEXTDDEA:DEA,NODRAW;
基準零線:=(0-分)/百*基+基點; NOTEXT基準零線:基準零線,COLORYELLOW,LINETHICK1;
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>=0,基準零線,基準零線+MACD,0,0),NODRAW;
STICKLINE(MACD<0,基準零線,基準零線+MACD,0,0),NODRAW;
DRAWTEXT(ISLASTBAR,基準零線,'零軸'),COLORYELLOW; 
技術人員回複
日期:2019/8/25 8:29
 參考:

DDIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DDEA:EMA(DDIF,9),NODRAW;
DMACD:(DDIF-DDEA)*2,NODRAW;

上市天數:=BARSCOUNT(C); 
N:=IF(上市天數<90,上市天數-1,90);
基點:=REFX1(LLV(L,N),10000); 
基:=REFX1(HHV(H,N),10000)-基點;
分:=REFX1(LLV(DDIF,N),10000); 
百:=REFX1(HHV(DDIF,N),10000)-分;
CC比:=(DDIF-分)/百; 
XCX:=CC比*基+基點;
DIF:=XCX; 
NOTEXTDDIF:DIF,NODRAW;
DEA:=EMA(DIF,9); 
NOTEXTDDEA:DEA,NODRAW;
基準零線:=(0-分)/百*基+基點; 
NOTEXT基準零線:基準零線,COLORYELLOW,LINETHICK1;
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>=0,基準零線,基準零線+MACD,0,0),NODRAW;
STICKLINE(MACD<0,基準零線,基準零線+MACD,0,0),NODRAW;
DRAWTEXT(ISLASTBAR,基準零線,'零軸'),COLORYELLOW;