0ANDHD>LD,HD,0),N,1);DMM:=SMA(I (WH6赢順V6.7)">
juhua624536.cn
我們隻提供有用的幹貨

麻煩老師把它改成文華的指标 (文華财經WH6赢順V6.7)

投資者咨詢:麻煩老師把它改成文華的指标 (文華财經WH6赢順V6.7)
來源:文華财經  日期:2019/8/24 21:42
麻煩老師改一下
 N(2,100,14)
 MTR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORRED;
MDI:DMM*100/TR,COLORGREEN;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
16;
30;
 謝謝
技術人員回複
日期:2019/8/25 8:31
您指标中缺少TR的定義 ,是MTR?

參考:

N:=14;
MTR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/MTR,COLORRED;
MDI:DMM*100/MTR,COLORGREEN;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
16;
30;